Cisco: konfigurowanie interfejsów routerów

Autor: Arkadiusz Tobiasz 25 marca 2010

W tym wpisie postaram się przybliżyć najważniejsze polecenia konfiguracyjne dotyczące interfejsów routera. Do projektowania topologii sieci będę korzystał z symulatora GNS3, który możecie pobrać stąd. Rozważymy trzy routery z serii c3700, które będą posiadały zarówno interfejsy dotyczące segmentów sieci lokalnej jak i interfejsów szeregowych. Topologię widać na poniższym rysunku.

Router „Zabrze” z routerem „Katowice” połączony jest za pomocą sieci LAN wykorzystując standard FastEthernet, natomiast router „Katowice” z routerem „Gliwice” siecią WAN wykorzystującą łącze szeregowe. Uruchamiamy teraz router „Zabrze” klikając prawym klawiszem myszy i klikając lewym na „Start”. Czynność powtarzamy tylko zamiast „Start” wybieramy „Konsola”. Ładowanie konsoli może trochę potrwać, które zakończy się pytaniem. Musimy wtedy wpisać w konsoli „no”. W taki sposób uzyskujemy dostęp do wykonywania poleceń z poziomu zwykłego użytkownika o czym informuje nas znak zachęty zakończony „>”. Okno konsoli możecie zobaczyć poniżej.

Poziom użytkownika jest poziomem domyślnym i zezwala on na wykonywanie tylko niektórych poleceń, takich ja sprawdzenie statusu routera. Pełen zestaw poleceń, w tym poleceń konfiguracyjnych zawiera poziom uprzywilejowany, który oznaczony jest znakiem zachęty zakończonym „#”. Przechodzimy do tego poziomu za pomocą komendy enable:

Router> enable

Następnie musimy przejść do trybu konfiguracyjnego za pomocą terminala, robimy to wpisując komendę configure terminal:

Router# configure terminal

Jak łatwo można dostrzec zmienił się nasz znak zachęty informując nas, że jesteśmy w trybie konfiguracyjnym poprzez dodanie (config). Rozpoczniemy od zdefiniowania hasła do trybu uprzywilejowanego, aby zapewnić ochronę przed nieautoryzowanym dostępem. Możemy to zrobić za pomocą dwóch komend enable secret <password> lub enable password <password>. Różnica miedzy nimi jest taka, że w przypadku pierwszej komendy hasło przechowywane jest w postaci zaszyfrowanej, a w przypadku drugiej komendy już nie. W związku z tym lepiej korzystać z enable secret:

Router(config)# enable secret cisco

Od tej chwili, aby przejść do trybu uprzywilejowanego należy podać hasło cisco. Teraz zmienimy logiczną nazwę routera na bardziej przyjazną, która pozwoli nam łatwiej poruszać się między routerami jak będziemy mieli otwartych kilka okienek konsoli. Nazwę logiczną routera definiujemy za pomocą polecenia hostname <name>:

Router(config)# hostname Zabrze

Jak możecie zauważyć nasz znak zachęty zmienił się i obecnie znajduje się w nim nasza nazwa logiczna routera. Możemy, więc przystąpić do konfiguracji interfejsów. Jak wynika z topologii router „Zabrze” jest połączony za pomocą interfejsu FastEthernet 0/0 z interfejsem FastEthernet 0/0 routera „Katowice”. W symulatorze GNS3 mamy bardzo użyteczne „drzewko”, które informuje nas w jaki sposób połączone są ze sobą routery tworzące daną topologię.

Bardzo ważne jest właściwe skonfigurowanie interfejsów routerów, poprzez zdefiniowanie odpowiednich dla nich parametrów komunikacyjnych. Rozpocznijmy od skonfigurowania interfejsu f 0/0 routera „Zabrze”:

Zabrze(config)# interface FastEthernet 0/0

Weszliśmy właśnie do trybu konfiguracyjnego interfejsu, znów nasz znak zachęty się zmienił i informuje nas, że możemy wykonywać polecenia do konfiguracji naszego interfejsu FastEthernet 0/0. Przypisujemy teraz mu adres IP i maskę podsieci.

Zabrze(config-if)# ip address 192.168.1.1 255.255.255.0

Nasz interfejs FastEthernet 0/0 ma przypisany adres IP 192.168.1.1 z maską 255.255.255.0. Teraz musimy jeszcze odblokować interfejs poprzez wyłączenie polecenia shutdown:

Zabrze(config-if)# no shutdown

Zmiany przechowywane są w pamięci RAM, aby je zapisać na stałe należy je przenieść do pamięci nieulotnej, tzw. NVRAM jako konfigurację startową:

Zabrze(config)# copy running-config startup-config

Aktualne zapis konfiguracji jak i konfigurację startową możemy wyświetlić za pomocą poleceń:

Zabrze# show running-config

Zabrze# show start

Natomiast ustawienia dla poszczególnych interfejsów możemy wykonać za pomocą komendy show ip interface:

Zabrze# show ip interface FastEthernet 0/0

To wszystko. Pozostaje jeszcze wyjście z trybu konfiguracyjnego za pomocą polecenia end i z trybu uprzywilejowanego za pomocą disable. Natomiast z konsoli wychodzimy za pomocą polecenia exit:

Zabrze(config-if)# end

Zabrze# disable

Zabrze> exit

Czas na router „Katowice”. Pominę szczegółowe opisywanie konfigurowania interfejsu FastEthernet 0/0 dla tego routera przedstawiając wszystkie wykonane komendy. Warto zwrócić uwagę, że można stosować skróty komend, co znacznie ułatwia pracę:

Router> en

Router# conf t

Router(config)# en sec cisco

Router(config)# host Katowice

Katowice(config)# int f0/0

Katowice(config-if)# ip address 192.168.1.2 255.255.255.0

Katowice(config-if)# no shut

Katowice(config)# copy running-config startup-config

Katowice(config)# end

W tym miejscu sprawdźmy, czy możemy spingować router „Zabrze”:

Katowice# ping 192.168.1.1

Jak widać na powyższym obrazku wszystko się powiodło. Router „Katowice” jednak ma jeszcze jeden interfejs, tym razem szeregowy, którego konfiguracja jest trochę bardziej skomplikowana. Musimy w konfiguracji oprócz parametrów warstwy sieciowej zdefiniować parametry warstwy łącza danych i fizycznej. Rozpoczynamy od przejśc do trybu konfiguracyjnego tego interfejsu i przypisania adresu IP oraz maski podsieci:

Katowice# configure terminal

Katowice(config)# interface serial 0/0

Katowice(config-if)# ip address 172.16.16.1 255.255.255.0

Katowice(config-if)# no shutdown

Rozważmy komunikację synchroniczną, typu punkt-punkt, gdzie router „Katowice” będzie urządzeniem aktywnym SCE, natomiast router „Gliwice” urządzeniem biernym DTE. W związku z tym musimy na tym routerze dodatkowo podać parametr zegara transmisji.

Katowice(config-if)# clock rate 128000

Pozostał nam jeszcze do skonfigurowania router „Gliwice”:

Router> en

Router# conf t

Router(conf)# en sec cisco

Router(conf)# host Gliwice

Gliwice(conf)# int s0/0

Gliwice(conf-if)# ip address 172.16.16.2 255.255.255.0

Gliwice(conf-if)# no shut

Tradycyjnie sprawdzamy łączność pomiędzy routerami:

Gliwice# ping 172.16.16.1

W kolejnym wpisie co nieco o routingu statycznym.

Jeden komentarz

  1. […] konfiguracji interfejsów możesz poczytać tutaj, więc ten element pominę i przejdę do konfiguracji protokołu OSPF. Na jednym routerze może […]

Odpowiedz

 

Arkadiusz Tobiasz student Akademii Ekonomicznej im. Karola Adamieckiego w Katowicach na specjalnościach informatyka ekonomiczna oraz rachunkowość. Więcej...

jQuery Validation i funkcja remote

Jakiś czas temu zwrócił się do mnie użytkownik z problemem. Chodzi o to, że korzysta on z pluginu walidacji jQuery, […]

Zend Framework: integracja z Uploadify

W tym wpisie postaram się przedstawić Wam w jaki sposób zintegrować skrypt Uploadify z Zend Frameworkiem. Dzięki temu będziemy mogli […]

Javascript: Czasowe wyświetlanie reklamy

Czasami chcemy, aby na pewnym elemencie naszej strony wyświetlała się reklama przez jakiś czas, a następnie zniknęła. W tym wpisie […]

Linux: backup wszystkich baz danych MySQL

Swego czasu pisałem o tym jak z poziomu konsoli można szybko i przyjemnie zrobić backup bazy MySQL. Wszystko jest ładnie […]